Dolby Stereo!!

Share your success stories with others

Moderator: Pablo

Post Reply
juski
Contributor
Posts: 127
Joined: Sun Jun 26, 2005 10:14 pm
Location: Manchester, UK

Dolby Stereo!!

Post by juski »

The LEAST Via could do is get the jumper settings for their board right in the manual!!! :twisted:

TWO HOURS I messed around with various settings to get SPDIF working...

So I swapped the jumper over on the motherboard, set minimyth to 'digital' sound, set everything else up...

Now able to watch movies & listen to music in glorious digital sound :D
The words 'digital' and 'quality' are not synonymous
shec0002
Member
Posts: 39
Joined: Mon Dec 01, 2003 10:46 pm
Location: Minnesota, USA
Contact:

Which board to you use?

Post by shec0002 »

Which board to you use? Are you willing to tell us your secret?
juski
Contributor
Posts: 127
Joined: Sun Jun 26, 2005 10:14 pm
Location: Manchester, UK

Post by juski »

My board is an EPIA-M10000. Once I got the jumper settings right it was just a matter of setting 'use AC3-passthru' in a mythtv config page and of course set minimyth.conf to 'analog+digital'.
The words 'digital' and 'quality' are not synonymous
JonathanL
New Member
Posts: 6
Joined: Fri Nov 04, 2005 5:27 am
Location: Maine, USA

Post by JonathanL »

I had a problem where I could not get AC3 audio to play back over the 2 channel analog output (M10000) using minimyth 0.18.1.8. Xine was playing the sound for all other video just fine, but it would not play AC3 sound on DVDs.

The problem stemmed from a line in xine's config file (/root/.xine/config) that read audio.output.speaker_arrangement:Pass Through. I changed this line to audio.output.speaker_arrangement:Stereo 2.0 and now I can enjoy Dolby Digital soundtracks over the 2 channel analog sound output.

Just for reference for anybody else that may come across this problem, this fix involved:
  • Using cramfsck to extract rootfs-minimyth-0.18.1.8
  • Changing the audio.output.speaker_arrangement setting in the file rootfs-ro/root/.xine/config to the value I described above
  • Using mkcramfs to rebuild the disk image that contains the modified xine config file
There may be a more efficient way to fix this, but the above steps worked for me! By the way, my minimyth.conf has the default MM_AUDIO_TYPE line: #MM_AUDIO_TYPE=analog
Hairlocks
Contributor
Posts: 107
Joined: Wed Aug 27, 2003 12:23 pm
Location: Reading, UK
Contact:

Post by Hairlocks »

Thanks JonathanL that looks great, I will give it a try tonight. I also have the DVD problem over analog.
pkahle
New Member
Posts: 4
Joined: Wed Nov 30, 2005 6:31 am

Quick test for JonathanL's solution

Post by pkahle »

Rather than rebuild the tarball, one solution I tried and I think worked (unless it's been updated in the rootfs of 0.18.1.8) is to provide a minimyth.script like the following:

Code: Select all

#! /bin/sh
sed -i {s/audio\.output\.speaker_arrangement\:Pass\ Through/audio.output.speaker_arrangement\:Stereo\ 2.0/} /root/.xine/config
(that should be two lines, the second starting with sed)

if you've already got a script, adding the sed line to it should work. much easier than messing with the cramfs.

unfortunately my problem was unrelated.

P
Post Reply