minimyth-0.4beta

Announce/Discuss projects you are working on for MiniMyth

Moderator: Pablo

lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

minimyth-0.4beta

Post by lmatter »

I have uploaded a beta of minimyth-0.4 (skipping 0.3). It contains the following updates:

mythfrontend from MythTV CVS as of last night.
Kernel 2.4.24-epia1
XFree 4.3.99.902 plus Thomas Hellstr
Last edited by lmatter on Fri Feb 27, 2004 11:11 am, edited 2 times in total.
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

Post by lmatter »

ok, a little more information. I threw this together last night and it seems to work ok. Much less stuttering.

The size is now around 28M. Check your pxelinux.cfg/default file to make sure your ramdisk is big enough.

The HWMPEG2 kernel arg is no longer needed, as you can choose between HWMPEG2 support in the mythfrontend setup screens.

Support for the grey Hauppauge remote that comes with pvr-350, when used with a Homebrew receiver. Specify LIRC=haup-hb2

Now redirects stdout and stderr from mythfrontend to /var/logl/mythfrontend.log. Please check this log file when reporting problems.

I forgot to fix the consoles, I'm doing that now and will reupload. It will be ready about 1:00pm PST

Thanks for any feedback.
oeris
New Member
Posts: 7
Joined: Sat Oct 04, 2003 9:13 pm

Bootsplash

Post by oeris »

Hi Larry,

I've done a bunch of modifications to minimyth, one of the cooler ones was to add bootsplash into it. Would you be interested in this? It doesn't add much to the splash (just the size of a jpg really)

I did this after modifying the bios boot logo (the big via thing) to my own. And everything is now graphical except for the stupid PXE loadup screens which I'm hoping to figure out one day.

Let me know if you need help on this front. It's pretty simple. And might be worth while.

Oguzhan
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

Post by lmatter »

Yes, I'm interested in this. I have a mythtv bootspash image from Oscar Carlsson, but I haven't had time to figure out how to use it.

If you are using GAR from CVS, can you send me any diffs to the kernel config, as it is from there I build it for minimyth-0.4

Yes, the PXE boot stuff is annoying (I'm grateful that it works, but it is annoying to watch).

Thanks,
Larry
oeris
New Member
Posts: 7
Joined: Sat Oct 04, 2003 9:13 pm

Post by oeris »

Ok, I'll check out the CVS, not sure if the particular kernel you use has the bootsplash support builtin, otherwise it's kernel patches as well. Since I doubt you'll need a progress bar, the bootsplash config will be simple. Then all you end up doing is run "splash" with some options to append the bootsplash jpg to the initrd. And the kernel upon boot sees the file in the initrd and expands it to use it. So you don't need any new binaries put in the minimyth distro, you only have to run that particular splash command after you build the initrd so it appends the proper image to it.

Once I get home I'll give better instructions and provide appropriate diffs.
oeris
New Member
Posts: 7
Joined: Sat Oct 04, 2003 9:13 pm

Post by oeris »

Also -epia7 is out...
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

Post by lmatter »

Ah. Initrd. I don't use one, well, not the way mandrake does anyway. What exacly does it do to an initrd?

Larry
zzo
Member
Posts: 15
Joined: Thu Jan 29, 2004 4:45 am

beta1 experiences

Post by zzo »

Doesn't work w/myth .12!! So after upgrading myth to .13 I get:
# cat mythfrontend.log
2004-01-30 20:22:20 mythfrontend version: 0.14.20040123-1 www.mythtv.org
2004-01-30 20:22:20 Enabled verbose msgs : important general
2004-01-30 20:22:20 Registering Internal as a media playback plugin.
2004-01-30 20:22:24 Connecting to backend server: 192.168.77.9:6543 (try 1 of 1)
2004-01-30 20:22:32 ReadStringList timeout (quick).
2004-01-30 20:22:32 Unexpected response to MYTH_PROTO_VERSION:
2004-01-30 20:22:32 Changing from None to None

(which was pretty much the same stuff I got when I was running myth-.12)

Do I need to run a CVS version of mythbackend?? That's a bummer if true.
mythfrontend starts up but when I try to go to 'Watch TV' the screen goes blank for 5 seconds & then the TV menu comes back up.
My mythbackend console running in '-v all' mode says:
2004-01-30 20:31:12 Unknown socket
2004-01-30 20:31:20 unknown socket

'Use VIA HW MPEG Decoding' is set in the 'Hardware Decoing Settings'
Exiting mythfrontend shows:
modprobe: Can't locate module /dev/apm_bios
a bunch of times and:
modprobe: Can't locate module via
[drm] failed to load kernel module "via"

that's about it.
Mark
zzo
Member
Posts: 15
Joined: Thu Jan 29, 2004 4:45 am

updated to mythbackend CVS...

Post by zzo »

.... and it's working.
I'm just watching straight TV - no remote or anything - need to figure out the ati_remote stuff.
Problem is the gar stuff is at myth-.13 & this stuff is at .14 CVS - what's it gonna be?
Why aren't you using myth-.13 in this beta? & is the next mini-myth version gonna be this
or the gar stuff?
Just wanna know what I should be working on...
thanks!
Mark
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

Post by lmatter »

Yeah, the minimyth beta requires a fairly recent CVS version on the backend. The frontend now tries to check the version of the backend, but the backend won't go along unless it's recent. That was that PROTO error you got.

The short story on minimyth versions is:
gar/cvs - stalled for the moment. I had a bunch of problems trying to do it the "wrong" way that I solved with fairly ugly hacks, finally couldn't take it anymore, and I'm going to redo it the "right" way. But I'm taking a little break.

In the meantime, MythTV-0.14 is probabaly going to happen any day now, so I wanted to be ready with something. Thus the beta, which is really minimyth-0.2 with a few things upgraded.

Larry.
zzo
Member
Posts: 15
Joined: Thu Jan 29, 2004 4:45 am

still going...

Post by zzo »

ati_remote works right out of the box, which is nice - I just copied 'xmodmap' over usr/X11R6/bin & changed my .xinitrc to be:

xmodmap /.xmodmap_myth | mythfrontend 2>&1 > /var/log/mythfrontend.log

& added this line to loadmods.script

insmod -r ati_remote

& stuck my compiled-for-2.4.24-epia1 ati_remote.o into lib/modules/2.4.24-epia1

I'll share my .xmodmap_myth file is anyone is interested.

Only kicker I've really run into is quitting out of myth just crashes the box.
After a 'quit & shutdown the box' I get a kernel panic after the 'System halted.'
It says:
System halted.
VFS: Cannot open root device "" or 03:03
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 03:03
like it's trying to reboot or something

Finally had to enable SMB support in the kernel & now samba runs too...
Mark

Last thing on my list is getting this distro to handle a CDRW/DVD player hooked up to the
USB port... (of course mythmusic & mythdvd are gonna have to get added too)
oeris
New Member
Posts: 7
Joined: Sat Oct 04, 2003 9:13 pm

Post by oeris »

Hey zzo,

I would be interested in your modmap.

Can you email it to me eris at ekls.zzz replace zzz with com

thanks.
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

Post by lmatter »

After a 'quit & shutdown the box' I get a kernel panic after the 'System halted.'
Oh that. If you have a keyboard on the frontend, just go into setup and change the halt command to "poweroff" (from "halt"). Otherwise you can use sql on the backend:

update settings set data='poweroff' where value='HaltCommand' and hostname = 'frontendhostname';

Maybe I should change halt to just call poweroff (via a script, a symlink would just tell busybox to "halt").

BTW, MythTV-0.14 is out and I've built it. I'll try to get a beta2 out tonight sometime.

The one thing I haven't been able to test much is lirc. It works for my setup (hauppauge remote with homebrew IR), but I'm not sure about the others. My Pinnacle remote died. In particular, not sure if irrecord works with the pinnacle IR receiver.

Larry
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

Post by lmatter »

Oh and Mark, shoot me your .xmodmap and I'll try to get ati remote support in.
zzo
Member
Posts: 15
Joined: Thu Jan 29, 2004 4:45 am

lost hardware acceleration...

Post by zzo »

When I recompiled my kernel to include SMB I managed to lose mpeg hardware decoding - when
you spin beta2 can you please compile SMB support into the kernel???
thanks!
Mark
Post Reply