MiniMyth rel-0.5

Announce/Discuss projects you are working on for MiniMyth

Moderator: Pablo

lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

MiniMyth rel-0.5

Post by lmatter »

Since Isaac will be releasing MythTV-0.15 to deal with Zap2it data-direct, I will be cutting a new release of minimyth to include it. I wasn't planning on changing anything other than upgrading the myth parts.

Larry
slifox
Member
Posts: 48
Joined: Sat Nov 22, 2003 11:31 pm

Post by slifox »

could you include mplayer and mythdvd, pleeeeeease? :)
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

Post by lmatter »

Probably not (actually, mplayer is already in there).

Sorry, but I'm going to try to do this quickly. I have to upgrade my own system as well, and try to keep WAF positive during the whole time.

If things go really smoothly, and I have some time, I'll try to look at it, but I doubt that will happen.

Larry
drsoran
Member
Posts: 12
Joined: Thu Dec 11, 2003 5:30 am

Post by drsoran »

lmatter wrote: Sorry, but I'm going to try to do this quickly. I have to upgrade my own system as well, and try to keep WAF positive during the whole time.
What's WAF? Wife acceptance factor? At least, that's what it means to me. I haven't told her yet we're down to 5 days of guide data. I'm hoping all her season finales are finished up this week, otherwise either MythTV 0.15 needs to get released or I've got to mess around with tv_grab_na_dd. ;-) It sounds like Isaac will get 0.15 out this week though so I'm crossing my fingers.
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

Post by lmatter »

Yes, Wife Acceptance Factor. Thankfully all her shows finish on Wednesday, and at that time I'm going to redo a whole bunch of stuff (including adding more drives and using LVM + XFS).

I may also upgrade to Mandrake 10. Anyone try it yet?

I'm going to try to get minimyth out before the guide data runs out. It's going to be close.

Larry
[/i]
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

Post by lmatter »

Isaac has released MythTV-0.15. Let the fun begin.

Larry
Eduardo
Contributor
Posts: 212
Joined: Thu Mar 04, 2004 6:30 pm
Location: Winnipeg, Canada

Post by Eduardo »

Yehaw! and away we go....

I'm scheduled to be at a bar tonight covering the Stanley Cup action... Okay I'm really more interested in the beer, wings and flirty waitress action....

I may just have to build it remotely from work... :roll:
drsoran
Member
Posts: 12
Joined: Thu Dec 11, 2003 5:30 am

Post by drsoran »

I wonder what will get out first. Minimyth 0.5 or mdz's Debian packages of Mythtv 0.15. At least I have all weekend to screw around with this if there are problems since all the good season finales are over for me. ;-)
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

Post by lmatter »

Well, looks like MDZ beat me to it. But my upgrade went successfully, and now I have over 300G of space for recordings. I decided not to move to Mandrake 10 since folks were having trouble buildind with it; still on 9.2.

I have built all the modules and am in the process of copying them over to minimyth. I have successfully tested mythfrontend 0.15 on the EPIA M.
Time permitting I should have a release candidate up Friday sometime.

Larry
Eduardo
Contributor
Posts: 212
Joined: Thu Mar 04, 2004 6:30 pm
Location: Winnipeg, Canada

Post by Eduardo »

I noticed Axel Thim at atrpms.net got his RPMs up for Fedora Core, so I will hopefully do an upgrade tonight.

Eduardo

PS we lost in hockey but the waitresses were in fine form.
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

MiniMyth-0.5beta1

Post by lmatter »

MiniMyth-0.5beta1. Get it while it's hot. MythVideo is not working yet :-(. Everything else is :-)

http://linpvr.org/rel-0.5beta1/README-0.5beta1.html

Appreciate all feedback.

Also, partly because I'm lazy, I have not changed the OSD fade times to zero like I did in 0.4. Isaac made a lot of improvements to the OSD fading so perhaps this is no longer necessary. It works without stuttering on my M 10000, stutters a little on my 6000.

Larry
Eduardo
Contributor
Posts: 212
Joined: Thu Mar 04, 2004 6:30 pm
Location: Winnipeg, Canada

Post by Eduardo »

I'm up. I will post how I did my upgrade to my backend later in the OT section.

Now it's hard to tell how well things are working because I'm looking with a more critical eye.

I need to tweak some backend stuff, cause I accidentally blew away my capture cards during setup. However I have noticed audio issue still exists when changing channels using the OSD and the prebuffering pause errors in the log.

The output seems more blocky, I thought it may be my default capture settings, but a replay of an old capture seems blocky (or is it just me?).

UPDATED: Watched more shows, I think it was the source channel, it appears as good as it always was.

I also see
svc: short len 0, dropping request
svc: bad direction 1664050031, dropping request
svc: short len 0, dropping request
svc: bad direction 1664050031, dropping request
at the end of dmesg.

Still testing..
Last edited by Eduardo on Sat May 29, 2004 6:55 am, edited 1 time in total.
Eduardo
Contributor
Posts: 212
Joined: Thu Mar 04, 2004 6:30 pm
Location: Winnipeg, Canada

Post by Eduardo »

You said mythvideo is not working however I don't know to what level. I can playback my movies but the IMDB does not work under automatic and manual
/usr/local/share/mythtv/mythvideo/scripts failed: Could not start process
Check VideoManager Settings
It calls a perl script and is looking for /usr/bin/perl which is not there.

I also had a weird issue with time. It did not set properly, I had his from time to time in 0.4 however. When I did it manually it worked and was close to the 36000 offset limit but still within it. I wonder if a cron job may be required if you leave the system on a long time?
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

Post by lmatter »

You said mythvideo is not working however I don't know to what level. I can playback my movies but the IMDB does not work under automatic and manual
Hmm. Looks like you got farther along than I did. Personally, I don't use MythVideo. I have three "test" movies that I try to play to see if it works. In rel-0.4 it played fine, but in rel-0.5beta1 mplayer seems to hang; The list of videos stays up, no picture.

Wrt IMDB, I didn't include perl in minimyth. I think adding it would add around 5 megs. So it will have to wait until the NFS based release (or maybe you could NFS mount it from your server and put it in the path).

Larry
Eduardo
Contributor
Posts: 212
Joined: Thu Mar 04, 2004 6:30 pm
Location: Winnipeg, Canada

Post by Eduardo »

Obviously the easy workaround for mythvideo is to lookup the videos on the backend system.
There is now a setting in mythvideo that lets you specify where to store the "posters" so instead of under the .mythtv/MythVideo directory, you can store them with the videos. This eliminates the need for IMDB on the front end.

I'm now curious as to how it was done before 0.15... It may be possible to rewrite.
Post Reply