minimyth Bloated edition

Announce/Discuss projects you are working on for MiniMyth

Moderator: Pablo

sgargash
Member
Posts: 13
Joined: Wed Nov 24, 2004 8:41 am

Post by sgargash »

nem,

Myth is started from /etc/X11/xinit/xinitrc. Unfortunately, the HOME environment variable is not set when this script is evaluated, so it drops through to the else clause at the bottom of the file. I added the following hack to the beginning of the file:

# This is a total hack
if [ -n $USER ]; then
export HOME="/root"
fi

This lets it use the same rc files that you'd use if you logged in as root and started X by hand.
monkeyBox
Member
Posts: 48
Joined: Sat Sep 06, 2003 6:22 am
Location: Kansas, USA

Post by monkeyBox »

How did you get modprobe lirc_serial to work? I emerged lirc, but when I do modprobe lirc_serial, it says "module lirc_serial not found"
monkeyBox
Member
Posts: 48
Joined: Sat Sep 06, 2003 6:22 am
Location: Kansas, USA

Post by monkeyBox »

figured it out. I had to set LIRC_OPTS. For anyone else wanting to do this, see the LIRC ebuild file (in /usr/portage/app-misc/lirc) for more information on how to set this variable.
Skaastrup
Member
Posts: 26
Joined: Mon Sep 13, 2004 5:27 pm
Location: Denmark

Post by Skaastrup »

I am trying to use this root fs on an M10000(non-nehemiah) The provided kernel does not start correctly, so i tried building it with i586 optimisations instead. But it still panics when i start saying something like:

Code: Select all

general protection fault: 0000 #1
CPU: 0
EIP: 0060:[] Not tainted
EFLAGS: 00010246 (2.6.8.1-epia1)
EIP is at via_init+0x7/0x40
eax: c030423c ebx: 00000000 ecx: 0000110b edx: c02cf108
esi: 00000000 edi: 00000000 ebp: 00000000 esp: c6411fc0
ds: 007b es: 007b ss: 0068
Process swapper (pid: 1, threadinfo=c6410000 task=c640f670)
Stack: 00000000 00000000 c034e29d 00000000 00000000 c034e31f 00000000 c035b430
c03426fb c01003c0 00000000 c01003e2 c0103cc5 00000000 00000000 00000000
Call Trace:
[] rng_init_one+0xd/0x50
[] rng_init+0x3f/0x70
[] do_initcalls+0x2b/0xb0
[] init+0x0/0xe0
[] init+0x22/0xe0
[] kernel_thread_helper+0x5/0x10
Code: 0f 32 89 c6 81 e6 f0 1f 80 ff 83 ce 40 39 c6 74 04 89 f0 0f
Kernel panic: Attempted to kill init!
So i'm wondering if my hardware is broken or i have missed some optimization settings in the kernel for non-nehemiah.

Havent fiddled with kernels before so i'm kind of a kernel-newbie.

Skaastrup
Hairlocks
Contributor
Posts: 107
Joined: Wed Aug 27, 2003 12:23 pm
Location: Reading, UK
Contact:

Post by Hairlocks »

Looks like I haven't managed it to bulid it to run on a i586. The initial gentoo build (system and kernel) was built in a chrooted enviroment on a i686 wichi has probably cause the problems. When I have the time I will try again from scratch with a i586 enviroment.
Skaastrup
Member
Posts: 26
Joined: Mon Sep 13, 2004 5:27 pm
Location: Denmark

Post by Skaastrup »

Ok.

Thanx for the reply. Couldn't se what was wrong and was starting to go insane...

-Skaastrup
Post Reply