HDTV in MiniMyth

Announce/Discuss projects you are working on for MiniMyth

Moderator: Pablo

Post Reply
Posts: 19
Joined: Tue Aug 17, 2004 7:51 am
Location: Denmark

HDTV in MiniMyth

Post by crax »


As I recently bought a HD-Ready TV and the new Via EN12000EG mainboard, which is capable of doing HD, I wanted to find out it MiniMyth was able to display content in HD quality...

My experience with HDTV is very limited - actually I had no knowledge all to begin with, but it starts getting better.

I will keep this thread updated with my progress in the project...


Step 1:
The EN12k board has onboard pin-headers for YPbPr, but no adapter was included in the box, so I made one myself. A Very simple instruction for the assembly can be found here: http://www.rokamp.dk/thomas/ypbpr/ypbpr.html

The adapter works fine and I can show the boot process in 480p (NTSC) or 576p (PAL). The real problem is, that when X starts, it fails to display the image.

Step 2:
I knew that X's way of showing anything is based on ModeLines. And I also knew that finding the correct ModeLine for a TV could be a pain. At least earlier. But I've found some good instructions doing so, using a piece of software called PowerStrip. The only "bad" thing is, that it runs in Windows.

I installed a harddrive in the box, and installed windows. With the help from some tutorials [ADD LINKS] I was able to create some working modelines. PowerStrip has a feature to save the timings as a X compatible modeline, so the next part was faily easy - putting the new modeline in minimyth.conf, and remove the harddisk.
After booting, I could read in the Xorg log, that still no screens was found. After further investigating the log it seemed, that my modelines wasn't compatible with the display driver...

I did some "reseach" on the OpenChrome site, and found out that the driver would always ignore custom modelines. :(

Step 3:
So... No custom modelines.
I then tried some of the buildin modes, like


but again - no screen found in X.
Again back to the OpenChrome site, this time to find the sourcefiles for the via driver. Here I realized, that other TV Types had been added, but was (not yet( added to the minimyth.conf documentation.
I added the new type to minimyth.conf:


In fact these directly points out that we want HDTV, and reading further into the sources showed that these new types had a few X modes, which I also added:


After a reboot... Still no screens...

Step 4:
More log to read... It seemed that the modes for the 720P and 1080I had a bug. I also think I have located the bug in the openChrome source files, so the next thing to do, was to compile a new set of drivers for the display adapter.
This lead to a full download and compile of X11 R7.0 before I even could think of compiling the drivers. And believe me - it takes looong time to compile X :)

But finally I have compiled the new drivers (svn version 208), with the bug fixed (hopefully).

Booting the box, starting X and... YES - a screen was found and the resolution was set at 1280x720p. At least that's what I can tell from the Xorg log.

When I come home today I will put the TV back on and boot the box - and hopefully see the MythTV gui in HD.

To be continued...[/url]
Last edited by crax on Wed Sep 13, 2006 9:32 pm, edited 1 time in total.
Posts: 19
Joined: Tue Aug 17, 2004 7:51 am
Location: Denmark

Post by crax »

Just a short update...

It seems that the first part of the driver bug has been fixed. I now get X started and MythTV frontend loaded. When I ask for a status from my TV it also says that the resolution is 720p - Success!

But - the image on the TV is only shown for about half a second then signal is lost for 1-2 seconds. And I have no idea why or how to fix it.
It could be a timing issue...? It could be anything.

Any input here would be much appreciated.

I'll see if I can get some input from the openChrome forums.

New Member
Posts: 1
Joined: Thu Jan 04, 2007 9:21 pm

Post by RichardBronosky »

Any updates?
Post Reply