problem building myth trunk 18339 & build 58 of minimyth

Help with using MiniMyth's build system

Moderator: Pablo

Post Reply
pleeke
Contributor
Posts: 203
Joined: Thu Jun 30, 2005 10:25 pm

problem building myth trunk 18339 & build 58 of minimyth

Post by pleeke »

Hi,

I'm using build58 of minimyth to build a mythtv trunk 18339 version of mythtv. I'm hitting the following error whenever the first mythplugin is built?

/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/lib/qt4/bin/moc -D_GNU_SOURCE -DPREFIX="/usr" -DMMX -Di386 -D_FI LE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_PLUGIN -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_SQL_LIB -DQT_XML_LIB -DQT_OPENGL_LIB -DQ T_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/lib/qt4/mkspecs/linux-g++- 32-garhost -I. -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/lib/qt4/include/QtCore -I/home/pleeke/svnroot/m inimyth/gar-minimyth/images/main/usr/lib/qt4/include/QtCore -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/li b/qt4/include/QtGui -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/lib/qt4/include/QtGui -I/home/pleeke/svnro ot/minimyth/gar-minimyth/images/main/usr/lib/qt4/include/QtOpenGL -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/ usr/lib/qt4/include/QtOpenGL -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/lib/qt4/include/QtXml -I/home/ple eke/svnroot/minimyth/gar-minimyth/images/main/usr/lib/qt4/include/QtXml -I/home/pleeke/svnroot/minimyth/gar-minimyth/images /main/usr/lib/qt4/include/QtSql -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/lib/qt4/include/QtSql -I/home/ pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/lib/qt4/include/Qt3Support -I/home/pleeke/svnroot/minimyth/gar-minimyt h/images/main/usr/lib/qt4/include/Qt3Support -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/lib/qt4/include - I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/include -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/mai n/usr/include -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/include -I/home/pleeke/svnroot/minimyth/gar-mini myth/images/main/usr/include -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/include/mythtv -I/home/pleeke/svn root/minimyth/gar-minimyth/images/main/usr/include/cdda -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/includ e -I. -I. -I/home/pleeke/svnroot/minimyth/gar-minimyth/images/main/usr/include miniplayer.h -o moc_miniplayer.cpp
make[5]: *** No rule to make target `/usr/lib/libmyth-0.22.so', needed by `libmythmusic.so'. Stop.
make[5]: *** Waiting for unfinished jobs....
make[5]: Leaving directory `/home/pleeke/svnroot/minimyth/gar-minimyth/script/myth-trunk/mythmusic/work/main.d/mythplugins- trunk-18339/mythmusic/mythmusic'
make[4]: *** [sub-mythmusic-make_default] Error 2
make[4]: Leaving directory `/home/pleeke/svnroot/minimyth/gar-minimyth/script/myth-trunk/mythmusic/work/main.d/mythplugins- trunk-18339/mythmusic'
make[3]: *** [sub-mythmusic-make_default] Error 2
make[3]: Leaving directory `/home/pleeke/svnroot/minimyth/gar-minimyth/script/myth-trunk/mythmusic/work/main.d/mythplugins- trunk-18339'
make[2]: *** [build-work/main.d/mythplugins-trunk-18339/Makefile] Error 2
make[2]: Leaving directory `/home/pleeke/svnroot/minimyth/gar-minimyth/script/myth-trunk/mythmusic'
make[1]: *** [../../myth-trunk/mythmusic/cookies/main.d/install] Error 2
make[1]: Leaving directory `/home/pleeke/svnroot/minimyth/gar-minimyth/script/meta/minimyth'
make: *** [imgdep-main] Error 2
pleeke@f8-mythtv:~/svnroot/minimyth/gar-minimyth/script/meta/minimyth$


Any idea as I'm not sure where to start on this (other than to disable all plugins :-()

Thanks
Peter
pleeke
Contributor
Posts: 203
Joined: Thu Jun 30, 2005 10:25 pm

Post by pleeke »

Actually I think this changeset in myth broke things (according to myth-dev list it sounds like it did for win32 builds with an error similar to what I've been getting). Just building again to see if reverting this change fixes things.

http://cvs.mythtv.org/trac/changeset/18316
Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo »

This was fixed by r3771 in the MiniMyth build system: http://code.google.com/p/minimyth/source/detail?r=3771.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.
Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo »

This fix is in test build 59b2
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.
Post Reply