0.21-fixes glvdpau19929.patch and mm issue ?

Help with using MiniMyth's build system

Moderator: Pablo

Post Reply
warpme
Contributor
Posts: 438
Joined: Fri Aug 26, 2005 8:17 pm

0.21-fixes glvdpau19929.patch and mm issue ?

Post by warpme »

Pablo,
FYI
I think I caught sort of conflict between latest glvdpau patch and rest of myth patches (assuming that for other myth setups, 19929 patch works OK) .
Issue is with non-VDPAU capable HW (6150, ffmpeg+xv) and LiveTV/Recordings playback - myth simply crasches.
On VDPAU HW (8200) all is OK.

Here are tests with 19778/19900 and 19794-2/19929 patches

19778 + 19794-2: OK
19900 + 19794-2: OK
19778 + 19929: NOK
19900 + 19929: NOK

It looks like 19929.patch issue. As I don't see on forums, that other ppl had issues with 19929 - probably my issue is mm specific.
I'm on GAR 53 build - but all packages are most fresh ones.

br
Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo »

Odd.

I am running it on 6150 hardware (as that is the only HVIDIA hardware I have) with FFmpeg+Xv and it works fine.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.
warpme
Contributor
Posts: 438
Joined: Fri Aug 26, 2005 8:17 pm

Post by warpme »

Pablo wrote:Odd.

I am running it on 6150 hardware (as that is the only HVIDIA hardware I have) with FFmpeg+Xv and it works fine.
Hmm,
Interesting.
I'm wonder why in Your makefile glvdpau patch isn't first patch applied to vanilla myth sources.
After all - having it as first on the list causes that sources to which patch will be applied will be close as possible to sources used by author of this patch (Jean-Yves).
Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo »

I was wrong. I do get the crash, but only when using a build that has VDPAU capable NVIDIA drivers. Supposedly, the latest patch requires the newer beta NVIDIA drivers in order not to crash. However, I tried with these beta drivers and it still crashes. Therefore, I have reverted to the earlier VDPAU patch.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.
warpme
Contributor
Posts: 438
Joined: Fri Aug 26, 2005 8:17 pm

Post by warpme »

Thing looks for me like nvidia drivers issue as any myth version with 19929.patch works OK on VDPAU supported hw, but not on non-VDPAU hw.
I tested it on 7050 (crashing) and 8200 (OK, regardless vdpau/vdpau or ffmpeg/vx)
br
Post Reply