Problem with openchrome DRM and latest SVN

Help with using MiniMyth's build system

Moderator: Pablo

Post Reply
mattj
Member
Posts: 18
Joined: Sat Dec 04, 2010 3:23 pm

Problem with openchrome DRM and latest SVN

Post by mattj »

Hi Pablo

I think there's a new issue with the openchrome drivers and the kernel in newest SVN minimyth, since the update to 3.6.11 Xorg shuts down as soon as it starts with this error from the kernel :

[drm:via_build_sg_info] *ERROR* Invalid DRM bitblt alignment

This happens on both my cle266 and cx700 boards. I've confirmed that this also happens using your 83b1 build as well as my builds, and rolling back to minimyth r9669 ( which I think is the commit before the kernel change ) gets everything working again on my cx700.

I've checked the changelog for the 3.6.11 and there's no changes I can see which might relate to this.

I've reported this on the openchrome list to see if they can shed any light on it.

There's also been some movement on the cle266 tv out issue, with latest openchrome git master the modes are now correctly detected and X starts up fine with no errors, as opposed to segfaulting, but I still have black screen on the output so more work is needed there.
mattj
Member
Posts: 18
Joined: Sat Dec 04, 2010 3:23 pm

Re: Problem with openchrome DRM and latest SVN

Post by mattj »

After more debugging, that DRM message is actually a red herring. The problem is the xinit, and fixing the warn/warning issue previously reported solves the problem.
Post Reply