ZOTAK IONITX-C HDMI

Ask for hardware advice here

Moderator: Pablo

Post Reply
rogerjames99
Member
Posts: 32
Joined: Sat Jan 12, 2008 1:53 am

ZOTAK IONITX-C HDMI

Post by rogerjames99 »

I am having trouble getting HDMI output on this board. Is there any special config I need? The only thing I have in at the moment is
MM_X_OUTPUT_HDMI='auto'

The end of my Xorg log looks like this:

(WW) Dec 02 00:28:09 NVIDIA(0): user-requested virtual screen size (1280 x 720).
(II) Dec 02 00:28:09 NVIDIA(0):
(II) Dec 02 00:28:09 NVIDIA(0): --- Done building ModePool for DFP-0 ---
(II) Dec 02 00:28:09 NVIDIA(0):
(II) Dec 02 00:28:09 NVIDIA(0):
(II) Dec 02 00:28:09 NVIDIA(0): --- Modes in ModePool for DFP-0 ---
(II) Dec 02 00:28:09 NVIDIA(0): "nvidia-auto-select" : 832 x 624 @ 74.6 Hz (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "832x624" : 832 x 624 @ 74.6 Hz (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "832x624_75" : 832 x 624 @ 74.6 Hz (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "800x600" : 800 x 600 @ 85.1 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "800x600_85" : 800 x 600 @ 85.1 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "800x600_75" : 800 x 600 @ 75.0 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "800x600_72" : 800 x 600 @ 72.2 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "800x600_60" : 800 x 600 @ 60.3 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "800x600_56" : 800 x 600 @ 56.2 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "720x400" : 720 x 400 @ 85.0 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "720x400_85" : 720 x 400 @ 85.0 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "700x525" : 700 x 525 @ 74.8 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "700x525d75" : 700 x 525 @ 74.8 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "700x525d60" : 700 x 525 @ 60.0 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "640x480" : 640 x 480 @ 85.0 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "640x480_85" : 640 x 480 @ 85.0 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "640x480_75" : 640 x 480 @ 75.0 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "640x480_73" : 640 x 480 @ 72.8 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "640x480_60" : 640 x 480 @ 59.9 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "640x400" : 640 x 400 @ 85.1 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "640x400_85" : 640 x 400 @ 85.1 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "640x350" : 640 x 350 @ 85.1 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "640x350_85" : 640 x 350 @ 85.1 Hz (from: X Server, VESA)
(II) Dec 02 00:28:09 NVIDIA(0): "512x384" : 512 x 384 @ 70.1 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "512x384d70" : 512 x 384 @ 70.1 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "512x384d60" : 512 x 384 @ 60.0 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "512x384d87i" : 512 x 384 @ 87.1 Hz Interlace DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "400x300" : 400 x 300 @ 72.2 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "400x300d72" : 400 x 300 @ 72.2 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "320x240" : 320 x 240 @ 72.8 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "320x240d73" : 320 x 240 @ 72.8 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "320x240d60" : 320 x 240 @ 60.1 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "320x175" : 320 x 175 @ 85.3 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): "320x175d85" : 320 x 175 @ 85.3 Hz DoubleScan (from: X Server)
(II) Dec 02 00:28:09 NVIDIA(0): --- End of ModePool for DFP-0: ---
(II) Dec 02 00:28:09 NVIDIA(0):
(II) Dec 02 00:28:09 NVIDIA(0): Assigned Display Device: DFP-0
(II) Dec 02 00:28:09 NVIDIA(0): Requested modes:
(II) Dec 02 00:28:09 NVIDIA(0): "1280x720"
(WW) Dec 02 00:28:09 NVIDIA(0): No valid modes for "1280x720"; removing.
(WW) Dec 02 00:28:09 NVIDIA(0):
(WW) Dec 02 00:28:09 NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) Dec 02 00:28:09 NVIDIA(0): "nvidia-auto-select".
(WW) Dec 02 00:28:09 NVIDIA(0):
(II) Dec 02 00:28:09 NVIDIA(0): Validated modes:
(II) Dec 02 00:28:09 NVIDIA(0): MetaMode "nvidia-auto-select":
(II) Dec 02 00:28:09 NVIDIA(0): Bounding Box: [0, 0, 832, 624]
(II) Dec 02 00:28:09 NVIDIA(0): DFP-0: "nvidia-auto-select"
(II) Dec 02 00:28:09 NVIDIA(0): Size : 832 x 624
(II) Dec 02 00:28:09 NVIDIA(0): Offset : +0 +0
(II) Dec 02 00:28:09 NVIDIA(0): Panning Domain: @ 832 x 624
(II) Dec 02 00:28:09 NVIDIA(0): Position : [0, 0, 832, 624]
(**) Dec 02 00:28:09 NVIDIA(0): Virtual screen size configured to be 1280 x 720
(II) Dec 02 00:28:09 NVIDIA(0):
(II) Dec 02 00:28:09 NVIDIA(0): Implicitly adding the following modes to X Screen 0 (these
(II) Dec 02 00:28:09 NVIDIA(0): will be available via XRandR and XF86VidMode):
(II) Dec 02 00:28:09 NVIDIA(0):
(II) Dec 02 00:28:09 NVIDIA(0): "800x600" : 800 x 600 @ 85.1 Hz
(II) Dec 02 00:28:09 NVIDIA(0): "800x600_75" : 800 x 600 @ 75.0 Hz
(II) Dec 02 00:28:09 NVIDIA(0): "800x600_72" : 800 x 600 @ 72.2 Hz
(II) Dec 02 00:28:09 NVIDIA(0): "800x600_60" : 800 x 600 @ 60.3 Hz
(II) Dec 02 00:28:09 NVIDIA(0): "800x600_56" : 800 x 600 @ 56.2 Hz
(II) Dec 02 00:28:09 NVIDIA(0): "720x400" : 720 x 400 @ 85.0 Hz
(II) Dec 02 00:28:09 NVIDIA(0): "700x525" : 700 x 525 @ 74.8 Hz DoubleScan
(II) Dec 02 00:28:09 NVIDIA(0): "700x525d60" : 700 x 525 @ 60.0 Hz DoubleScan
(II) Dec 02 00:28:09 NVIDIA(0): "640x480" : 640 x 480 @ 85.0 Hz
(II) Dec 02 00:28:09 NVIDIA(0): "640x480_75" : 640 x 480 @ 75.0 Hz
(II) Dec 02 00:28:09 NVIDIA(0): "640x480_73" : 640 x 480 @ 72.8 Hz
(II) Dec 02 00:28:09 NVIDIA(0): "640x480_60" : 640 x 480 @ 59.9 Hz
(II) Dec 02 00:28:09 NVIDIA(0): "640x400" : 640 x 400 @ 85.1 Hz
(II) Dec 02 00:28:09 NVIDIA(0): "640x350" : 640 x 350 @ 85.1 Hz
(II) Dec 02 00:28:09 NVIDIA(0): "512x384" : 512 x 384 @ 70.1 Hz DoubleScan
(II) Dec 02 00:28:09 NVIDIA(0): "512x384d60" : 512 x 384 @ 60.0 Hz DoubleScan
(II) Dec 02 00:28:09 NVIDIA(0): "512x384d87i" : 512 x 384 @ 87.1 Hz Interlace DoubleScan
(II) Dec 02 00:28:09 NVIDIA(0): "400x300" : 400 x 300 @ 72.2 Hz DoubleScan
(II) Dec 02 00:28:09 NVIDIA(0): "320x240" : 320 x 240 @ 72.8 Hz DoubleScan
(II) Dec 02 00:28:09 NVIDIA(0): "320x240d60" : 320 x 240 @ 60.1 Hz DoubleScan
(II) Dec 02 00:28:09 NVIDIA(0): "320x175" : 320 x 175 @ 85.3 Hz DoubleScan
(II) Dec 02 00:28:09 NVIDIA(0):
(**) Dec 02 00:28:10 NVIDIA(0): DPI set to (101, 101); computed from "DisplaySize" Monitor
(**) Dec 02 00:28:10 NVIDIA(0): section option
(==) Dec 02 00:28:10 NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX
(II) Dec 02 00:28:10 NVIDIA: Reserved 253.69 MB of virtual memory for indirect framebuffer
(II) Dec 02 00:28:10 NVIDIA: access.
(II) Dec 02 00:28:10 NVIDIA(0): Initialized GPU GART.
(II) Dec 02 00:28:10 NVIDIA(0): kernel module enabled successfully
(II) Dec 02 00:28:10 NVIDIA(0): GPU initialized
(II) Dec 02 00:28:10 NVIDIA(0): Interrupts enabled
(II) Dec 02 00:28:10 NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Dec 02 00:28:10 NVIDIA(0): First mode initialized
(II) Loading extension NV-GLX
(II) Dec 02 00:28:10 NVIDIA(0): Initialized OpenGL Acceleration
(II) Dec 02 00:28:10 NVIDIA(0): Visuals set up
(II) Dec 02 00:28:10 NVIDIA(0): Pixmap depths set up
(II) Dec 02 00:28:10 NVIDIA(0): GLX visuals set up
(II) Dec 02 00:28:10 NVIDIA(0): Framebuffer set up
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) Dec 02 00:28:10 NVIDIA(0): Initialized X Rendering Acceleration
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) Dec 02 00:28:10 NVIDIA(0): Default colormap initialized.
(II) Dec 02 00:28:10 NVIDIA(0): Palette loaded
(II) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(II) Dec 02 00:28:10 NVIDIA(0): Screen initialization complete
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX
(II) config/udev: Adding input device "Power Button" (/dev/input/event0)
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 2.3.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 4.0
(**) "Power Button": always reports core events
(**) "Power Button": Device: "/dev/input/event0"
(II) "Power Button": Found keys
(II) "Power Button": Configuring as keyboard
(II) XINPUT: Adding extended input device ""Power Button"" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/udev: Adding input device "Power Button" (/dev/input/event1)
(**) "Power Button": always reports core events
(**) "Power Button": Device: "/dev/input/event1"
(II) "Power Button": Found keys
(II) "Power Button": Configuring as keyboard
(II) XINPUT: Adding extended input device ""Power Button"" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/udev: Adding input device "HDA Digital PCBeep" (/dev/input/event2)
(**) "HDA Digital PCBeep": always reports core events
(**) "HDA Digital PCBeep": Device: "/dev/input/event2"
(WW) "HDA Digital PCBeep": Don't know how to use device
(II) UnloadModule: "evdev"
(EE) PreInit returned NULL for ""HDA Digital PCBeep""
(II) config/udev: Adding input device (null) (/dev/input/mice)
(**) (unnamed): always reports core events
(**) (unnamed): Device: "/dev/input/mice"
(EE) ioctl EVIOCGNAME failed: Inappropriate ioctl for device
(II) UnloadModule: "evdev"
(EE) PreInit returned NULL for "(unnamed)"
root@hdfe:/var/log #

Have I missed something simple. The X server is running but nothing is on the screen.

Roger
rogerjames99
Member
Posts: 32
Joined: Sat Jan 12, 2008 1:53 am

Re: ZOTAK IONITX-C HDMI

Post by rogerjames99 »

I sorted it out. The HDMI output appears to X as the second digital flat panel display. So MM_X_HDMI_OUTPUT='1' is needed.

My next problem is audio. Does anyone know how to configure the high definition audio to be routed via HDMI? The ZOTAK board is supposed to support this, but I cannot get any audio out of the HDMI connected TV (Samsung) speakers.

Roger
Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: ZOTAK IONITX-C HDMI

Post by Pablo »

On my NVIDIA boards that support HDMI, the ALSA device for the HDMI output is different from the ALSA device for the SPDIF output. It is 3 rather than 1. Therefore, I set

Code: Select all

MM_AUDIO_DEVICE_NUMBER='3'
in my minimyth.conf in order to route sound through my HDMI output by default.

You should also be able to set the audio output device to ALSA:hdmi in mythtv. However, you may have problems when sample rate of the audio is not supported by you system.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.
Post Reply