Page 1 of 1

Problem with hombrew IR reciever on COM2

Posted: Sun May 28, 2006 8:35 am
by Micke

I'm probably doing something very wrong here but hopefully someone have a clue on what?
0.19-13beta2 on Epia M10k, 512 MB over NFS-root, homebrew IR-reciever on COM2. Everything is fine until Lirc. I think I have tried every possible combination in minimyth.conf for lirc_serial on ttyS1. Bootprocess just idles out, waiting for Lirc divice not found.

Is COM2 realy supported in Minimyth?

Just for info this box is current working 100% on FC4 diskless but I got curious about Minimyth and decided to give it a chance.


Posted: Sun May 28, 2006 10:48 pm
by Dorant
I built the same simple ir-thingy and used the internal comport on an Epia M10k. It worked fine here..connection-wise...but when using it with my Harmony 525 it gave me double-keypress in the Myth menus. The lack of cpu-power or late interupts seemed to make lLrc miss some wave's or something. It got out of sync and according to Lirc's logs it regenerated the key-command to myth..quite annoying..and useless on my system.
The solution was to build the less cpu/time-intensive IRMan (i.e. ). Works like a charm everytime.

I used these settings for the simple IR-receiver connected to the internal comport socket: (uncommened that is..)
# Serialport

// Bjorn

Posted: Mon May 29, 2006 4:32 pm
by lmatter
Strange that you had that problem. I use the homebrew receiver on ME6000s (which are slower) and have no problems.

Not sure if item (5) in the Software setup section of the lirc faq applies here but might be worth a look:


Posted: Mon May 29, 2006 6:57 pm
by Micke

Problem solved. I really was doing something very wrong, I should have known ;-(
I used MM_LIRC_DEVICE=/dev/ttyS1 instead of MM_LIRC_DEVICE=/dev/lirc0

Thank's Dorant and Imatter


Posted: Wed May 31, 2006 11:01 am
by Dorant
Yes, a bit strange. I worked perfectlly when using irw via telnet to test it, but using it in mythtv gave me some errors in the lirc-log.
I added/changed all the values in the lircrc to make it happy, but it didn't like me at all. Might be some faulty irq settings in bios or something..I go the feeling that it happend while the graphics was updating/drawn.
Anyway, my remote works as it is now :D